Performance Issue
Incident Report for Capital International Investments
Resolved
This incident has been resolved.
Posted Dec 31, 2024 - 07:25 GMT
Investigating
We are currently investigating an issue affecting some systems.

This may impact our ability to process certain requests and in the meantime, we apologise for any inconvenience. As we continue our investigations should you have any specific queries please contact Client Services via clientservices@capital-iom.com.
Posted Dec 30, 2024 - 14:18 GMT
This incident affected: Spectrum (Reporting, Deal Instructions), Proton (Reporting, Deal Instructions), and Capital API (Deal Instructions).